KENNTNISSE · LINUXERWERFER
403 Verbotener Fehler
Letzte Aktualisierung 2025-10-11
Ein "403 Forbidden"-Fehler ist ein Antwortcode von Apache, wenn die angeforderte Aktion aus Sicherheitsgründen nicht abgeschlossen werden kann.
Es gibt ein paar gemeinsame Dinge, die passieren könnten, um dies zu verursachen , wie z. B.:
- .htaccess Dateiregeln
- Unzureichend Genehmigungen über eine Akte
- Falsch Eigentum einer Akte
- ModSecurity Regel löst aus und verweigert den Zugriff mit einem 403 verboten
- Falsche IP-Adresse: Ein Domainname leitet Sie zu einer falschen oder veralteten IP-Adresse, die eine Website hostet, die Sie daran hindert, Zugang zu erhalten
- WordPressInkompatible oder fehlerhafte Plugins
Der einfachste Weg, um die Ursache eines 403-Fehlers zu ermitteln, besteht darin, das Apache-Fehlerprotokoll mit dem Befehl "tail" zu versehen, während Sie den 403-Fehler in Ihrem Browser replizieren, indem Sie die Seite aktualisieren, auf der Sie den 403-Fehler sehen:
-bash-4.2# tail -fn0 /etc/apache2/logs/error_log
[Wed May 20 00:45:52.779769 2020] [core:crit] [pid 4292] (13)Permission denied: [client 10.3.17.102:57708] AH00529: /home/user/public_html/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/home/error/public_html/' is executable
Permissions & Ownership: Der obige Fehler zeigt ein Problem beim Zugriff auf die .htaccess-Datei an. Wenn Sie Dateien überprüfen, bei denen Apache ein Berechtigungsproblem meldet, Wir müssen sicherstellen, dass sie über korrekte Berechtigungen verfügen (644 für die meisten Dateien, 755 für die meisten Verzeichnisse) und über das richtige Eigentum verfügen (user:user).
htaccessEin weiteres häufiges Element, das 403 Fehler verursacht, sind .htaccess-Regeln wie 'Optionen -Indexes' oder 'Deny from'-Regeln:
-bash-4.2# cat .htaccess
Options -Indexes
deny from all
Die Regel 'Optionen -Indexes' verhindert, dass ein Verzeichnis geladen wird, wenn keine 'Index'-Datei vorhanden ist, wie z. B. index.php oder index.html. Die Regel 'Deny from' verweigert den Zugriff auf die Website auf bestimmte IP-Adressen, IP-Bereiche oder alle, abhängig von der verwendeten .htaccess-Regel. Wenn eine .htaccess-Regel eine 403-Seite verursacht, ähnelt das Apache-Fehlerprotokoll im Allgemeinen diesem:
[Wed May 20 00:55:52.778579 2020] [access_compat:error] [pid 4292] [client 10.3.17.102:57869] AH01797: client denied by server configuration: /home/user/public_html/
Dies kann durch Hinzufügen einer Indexdatei (im Falle von Options-Indexes) oder Entfernen der Zeile "Deny from all" aus der .htaccess-Datei korrigiert werden.
Was ist ModSecurity?
ModSecurity ist ein Open-Source ‘Web Application Firewall‘ das alle HTTP-Anfragen und -Antworten überprüft. ModSecurity versucht, bösartige Anfragen zu verhindern und mögliche Code-Lecks zu vermeiden. ModSecurity verwendet reguläre Ausdrücke, die versuchen, häufig verwendete Angriffe zu entsprechen. Es wird dann einen 403-Fehler auslösen, wenn eine Regel ausgelöst wird. Melden Sie sich in Ihrem Systemsteuerungssystem an und deaktivieren Sie ModSecurity für die Domain. Wenn dadurch der Fehler behoben wird, wenden Sie sich an Ihren Webhost, um das Problem zu untersuchen.
Falsche IP-Adresse: Überprüfen Sie Ihren Datensatz
Ein weiterer möglicher Grund für Ihren 403 verbotenen Fehler ist, dass Ihr Domainname auf eine falsche IP-Adresse verweist, bei der Sie nicht berechtigt sind, den Inhalt der Website anzuzeigen. Um das zu umgehen, vergewissern Sie sich, dass Ihr Domainname auf die richtige IP-Adresse zeigt. Ihre Domain könnte immer noch auf Ihren vorherigen Webhost verweisen, wenn Sie zu einem neuen migriert sind und vergessen haben, Ihre Nameserver zu aktualisieren. Ein 403-Fehlerstatuscode wird ausgelöst, wenn Ihr vorheriger Host Ihr Konto kündigt.
Deaktivieren Sie Ihre WordPress Plugins und identifizieren Sie fehlerhafte Plugins
Wie bereits erwähnt, kann der 403 Forbidden-Fehler auch durch ein fehlerhaftes Plugin verursacht werden. Um festzustellen, ob dies der Fall ist, müssen Sie Ihre Plugins deaktivieren und dann einzeln reaktivieren. Um zu starten, verbinden Sie sich mit Ihrer Website über FileZilla oder den Dateimanager in Ihrem Hosting-Konto. Öffnen Sie dann den Ordner wp-content im Stammverzeichnis Ihrer Website und suchen Sie den Ordner Plugins. Klicken Sie mit der rechten Maustaste auf den Ordner Plugins und wählen Sie Rename.
Geben Sie dem Ordner als nächstes einen neuen Namen, z. B. “plugins test”. Dadurch werden automatisch alle Ihre Plugins deaktiviert.   Wenn Sie nach dem Umbenennen des Ordners auf Ihre Website zugreifen können, wurde der 403 Forbidden-Fehler durch ein glitchy-Plugin verursacht. Ihr nächster Schritt ist herauszufinden, welcher es ist.
Kehren Sie zuerst zum Stammverzeichnis Ihrer Website zurück und benennen Sie den Ordner Plugins zurück in “ Plugins ”. Navigieren Sie dann zur Plugins-Seite in Ihrem WordPress-Dashboard und aktivieren Sie die Plugins einzeln. Tun Sie dies, bis Sie den Fehler reproduzieren können. Sobald du das fehlerhafte Plugin identifiziert hast, kannst du es entweder entfernen oder den Entwickler um Unterstützung bitten.
403 Verbotene Fehlervariationen
Wie viele andere HTTP-Statuscodes gibt es viele verschiedene Variationen, wie sich dieser Fehlercode darstellt.
Hier sind einige häufige Variationen, die Sie möglicherweise stoßen:
- “ Forbidden – You don’t have permission to access / on this server”
- “403 – Verboten: Der Zugang wird verweigert”
- “Fehler 403 – Verboten ”
- “403 – Forbidden Error – Sie dürfen nicht auf diese Adresse zugreifen”
- “403 Verboten – nginx”
- “HTTP Fehler 403 – Verboten – Sie haben keine Berechtigung, auf das von Ihnen angeforderte Dokument oder Programm zuzugreifen”
- “403 Verboten – Zugriff auf diese Ressource auf dem Server wird verweigert”
- “403. Das ist ein Fehler. Ihr Client hat keine Berechtigung, URL / von diesem Server zu erhalten”
- “Sie sind nicht berechtigt, diese Seite anzusehen”
- &ldquo Es scheint, dass sie don & rsquo; keine erlaubnis haben, auf diese seite zuzugreifen. ”
Kontaktieren Sie uns, wenn Sie noch anwesend sind, nachdem Sie die oben genannten Lösungen ausprobiert haben.
Sagen Sie uns, was aufbleiben muss.
Ein kurzes Gespräch mit einem Ingenieur. Kein quote-bot, keine callback-warteschlange.