Wissensdatenbank · Anleitungen (Shared Hosting)
Wie greife ich ohne die temporäre URL mit der Tilde (~) auf eine Website zu?
Zuletzt aktualisiert am 2020-06-15
Da auf einigen Servern der mod_userdir-Schutz aktiviert ist, müssen manche unserer Kunden die Website möglicherweise anzeigen, bevor sie vollständig propagiert ist. Dieser Knowledgebase-Artikel beschreibt daher eine alternative Methode, um die Website ohne die Tilde im Pfad aufzurufen.
Durchsuchen Sie das folgende Verzeichnis in Ihrem C Drive >> Windows >> System32 >> Treiber >> Etc >> Bearbeiten Sie die Datei mit dem Namen "Hosts" mit einem Notizblock.
Standardmäßig sollte dort eine Zeile wie die folgende vorhanden sein:
"127.0.0.1 localhost"
Gehen Sie in die nächste Zeile und fügen Sie Folgendes hinzu:
23.227.166.160 tempdomain.dev
23.227.166.160 www.tempdomain.dev
Beachten Sie: Ersetzen Sie tempdomain.dev durch Ihre eigene Domain und 23.227.166.160 durch die IP-Adresse, die Ihrem Konto zugewiesen wurde.
Speichern Sie die Datei und versuchen Sie, Ihre Domain anzupingen. Sie sollte auf die IP-Adresse verweisen, die Sie in der hosts-Datei eingetragen haben. Wenn Sie nun Ihre Website aufrufen, sollte die Anfrage an unseren Server bzw. an die in der hosts-Datei eingetragene IP-Adresse gehen. So gehen Sie bei den gängigsten Betriebssystemen vor:
Für Windows 8
Durchsuchen Sie das folgende Verzeichnis in Ihrem C Drive >> Windows >> System32 >> Treiber >> Etc >> Bearbeiten Sie die Datei mit dem Namen "Hosts" mit einem Notizblock.
Standardmäßig sollte dort eine Zeile wie die folgende vorhanden sein:
"127.0.0.1 localhost"
Gehen Sie in die nächste Zeile und fügen Sie Folgendes hinzu:
23.227.166.160 tempdomain.dev
23.227.166.160 www.tempdomain.dev
Beachten Sie: Ersetzen Sie tempdomain.dev durch Ihre eigene Domain und 23.227.166.160 durch die IP-Adresse, die Ihrem Konto zugewiesen wurde.
Speichern Sie die Datei und versuchen Sie, Ihre Domain anzupingen. Sie sollte auf die IP-Adresse verweisen, die Sie in der hosts-Datei eingetragen haben. Wenn Sie nun Ihre Website aufrufen, sollte die Anfrage an unseren Server bzw. an die in der hosts-Datei eingetragene IP-Adresse gehen. So gehen Sie bei den gängigsten Betriebssystemen vor:
Windows 8, Windows 7 und Windows Vista
Windows 8, Windows 7 und Windows Vista verwenden die Benutzerkontensteuerung (User Account Control, UAC). Daher muss der Editor (Notepad) als Administrator ausgeführt werden.Für Windows 8
- Drücken Sie die Windows-Taste.
- Geben Sie Notepad in das Suchfeld ein.
- Klicken Sie in den Suchergebnissen mit der rechten Maustaste auf Notepad und wählen Sie Als Administrator ausführen.
- Öffnen Sie in Notepad die folgende Datei: c:\Windows\System32\Drivers\etc\hosts
- Nehmen Sie die erforderlichen Änderungen an der Datei vor.
- Klicken Sie auf Datei > Speichern , um Ihre Änderungen zu speichern.
- Klicken Sie auf Start > Alle Programme > Zubehör.
- Klicken Sie mit der rechten Maustaste Notepad und wählen Sie Als Administrator ausführen.
- Klicken Sie auf Fortfahren auf Windows benötigt Ihre Berechtigung UAC-Fenster.
- Wenn Notepad geöffnet wird, klicken Sie auf Datei > Öffnen.
- Öffnen Sie in der Dateiname Feld ein und geben Sie Folgendes ein: C:\Windows\System32\Drivers\etc\hosts.
- Klicken Sie auf Öffnen Sie.
- Nehmen Sie die erforderlichen Änderungen an der Datei vor.
- Klicken Sie auf Datei > Speichern , um Ihre Änderungen zu speichern.
Windows NT, Windows 2000 und Windows XP
- Klicken Sie auf Start > Alle Programme > Zubehör > Notepad.
- Klicken Sie auf Datei > Öffnen.
- Öffnen Sie in der Dateiname Feld ein und geben Sie Folgendes ein: C:\Windows\System32\Drivers\etc\hosts.
- Klicken Sie auf Öffnen Sie.
- Nehmen Sie die erforderlichen Änderungen an der Datei vor.
- Klicken Sie auf Datei > Speichern , um Ihre Änderungen zu speichern.
Linux
- Öffnen Sie ein Terminalfenster.
- Öffnen Sie das Menü hosts Datei in einem Texteditor (Sie können einen beliebigen Texteditor verwenden), indem Sie die folgende Zeile eingeben:
sudo nano /etc/hosts
- Geben Sie Ihr Domänenbenutzerkennwort ein.
- Nehmen Sie die erforderlichen Änderungen an der Datei vor.
- Drücken Sie Strg-x.
- Wenn Sie gefragt werden, ob Sie Ihre Änderungen speichern möchten, antworten Sie mit y.
Mac OS X 10.0 bis 10.1.5
- Öffnen Sie /Applications/Utilities/NetInfo Manager.
- Um die Bearbeitung der NetInfo-Datenbank zu ermöglichen, klicken Sie auf das Vorhängeschloss in der linken unteren Ecke des Fensters.
- Geben Sie Ihr Domänenbenutzerkennwort ein und klicken Sie auf OK.
- Wählen Sie in der zweiten Spalte der Browseransicht den Knoten mit dem Namen
machines.
Sie sehen Einträge für-DHCP-,broadcasthostundlocalhostin der dritten Spalte. - Wählen Sie in der dritten Spalte
localhost. - Wählen Sie in der Eingabeaufforderung Edit Menü die Option Duplizieren. (Der schnellste Weg, einen neuen Eintrag zu erstellen, besteht darin, einen vorhandenen Eintrag zu duplizieren.)
Eine Bestätigungsmeldung wird angezeigt. - Klicken Sie auf Duplizieren.
Ein neuer Eintrag mit dem Namenlocalhost copywird angezeigt, und seine Eigenschaften erscheinen unterhalb der Browseransicht. - Doppelklicken Sie auf den Wert der Eigenschaft
ip_addressund geben Sie die IP-Adresse des anderen Computers ein. - Doppelklicken Sie auf den Wert der Eigenschaft
nameund geben Sie den gewünschten Hostnamen für den anderen Computer ein. - Klicken Sie auf den Link
servesund wählen Sie Löschen aus dem Menü Edit einrichten. - Wählen Sie in der Eingabeaufforderung Datei Menü die Option Speichern.
Eine Bestätigungsmeldung wird angezeigt. - Klicken Sie auf Diese Kopie aktualisieren.
- Wiederholen Sie die Schritte 6 bis 12 für jeden weiteren Hosteintrag, den Sie hinzufügen möchten.
- Wählen Sie im Menü „NetInfo Manager“ den Eintrag Beenden.
Sie müssen den Computer nicht neu starten.
Mac OS X 10.6 bis 10.15 und höher
- Öffnen Sie Programme > Dienstprogramme > Terminal.
- Öffnen Sie das Menü hosts Datei, indem Sie die folgende Zeile im Terminalfenster eingeben:
sudo nano /private/etc/hosts
- Geben Sie bei Aufforderung Ihr Domain-Benutzerpasswort ein.
- Bearbeiten Sie die hosts Datei.
Die Datei enthält einige Kommentare (Zeilen, die mit dem Symbol#beginnen) sowie einige Standard-Hostnamenzuordnungen (zum Beispiel 127.0.0.1 – localhost). Fügen Sie Ihre neuen Zuordnungen nach den Standardzuordnungen hinzu. - Speichern Sie die Hosts-Datei, indem Sie folgende Tasten drücken: Control+x und Beantwortung y.
dscacheutil -flushcache sudo killall -HUP mDNSResponderDie neuen Zuordnungen sollten nun wirksam sein.
Tell us what you need
Compare available plans or describe your workload so we can discuss a suitable starting point.