Base de conocimientos · Guías prácticas (alojamiento compartido)
¿Cómo acceder a un sitio sin la URL temporal con el signo de tilde (~)?
Última actualización: 2020-06-15
Como tenemos la protección mod_userdir en algunos servidores, es posible que algunos de nuestros clientes necesiten ver el sitio mientras este se propaga por completo. Por ello, esta base de conocimientos le guiará a través de un método alternativo para ver el sitio sin el signo de tilde.
Examine el siguiente directorio en su C Drive ó Windows ó trono System32 ó Confesores ón Yc ón Edita el archivo llamado "hosts" con un notepad.
De forma predeterminada, debería haber una línea como esta:
"127.0.0.1 localhost"
Vaya a la siguiente línea y añada esto:
23.227.166.160 tempdomain.dev
23.227.166.160 www.tempdomain.dev
Tenga en cuenta que debe reemplazar tempdomain.dev por su propio dominio y cambiar 23.227.166.160 por la IP asignada a su cuenta.
Guarde el archivo e intente hacer ping a su dominio. Debería apuntar a la IP que indicó en el archivo hosts. Y si ahora intenta acceder a su sitio, debería dirigirse a nuestro servidor o a la IP que indicó en el archivo hosts. A continuación le explicamos cómo hacerlo en los sistemas operativos más comunes;
Para Windows 8
Examine el siguiente directorio en su C Drive ó Windows ó trono System32 ó Confesores ón Yc ón Edita el archivo llamado "hosts" con un notepad.
De forma predeterminada, debería haber una línea como esta:
"127.0.0.1 localhost"
Vaya a la siguiente línea y añada esto:
23.227.166.160 tempdomain.dev
23.227.166.160 www.tempdomain.dev
Tenga en cuenta que debe reemplazar tempdomain.dev por su propio dominio y cambiar 23.227.166.160 por la IP asignada a su cuenta.
Guarde el archivo e intente hacer ping a su dominio. Debería apuntar a la IP que indicó en el archivo hosts. Y si ahora intenta acceder a su sitio, debería dirigirse a nuestro servidor o a la IP que indicó en el archivo hosts. A continuación le explicamos cómo hacerlo en los sistemas operativos más comunes;
Windows 8, Windows 7 y Windows Vista
Windows 8, Windows 7 y Windows Vista utilizan el Control de cuentas de usuario (UAC), por lo que el Bloc de notas debe ejecutarse como administrador.Para Windows 8
- Presione la tecla Windows.
- Escriba Bloc de notas en el campo de búsqueda.
- En los resultados de la búsqueda, haga clic con el botón derecho en Bloc de notas y seleccione Ejecutar como administrador.
- En el Bloc de notas, abra el siguiente archivo: c:\Windows\System32\Drivers\etc\hosts
- Realice los cambios necesarios en el archivo.
- Haga clic en Archivo > Guardar para guardar los cambios.
- Haga clic en Inicio > Todos los programas > Accesorios.
- Haga clic con el botón derecho Bloc de notas y seleccione Ejecutar como administrador.
- Haga clic en Continuar en el Windows necesita su permiso ventana de Control de cuentas de usuario (UAC).
- Cuando se abra el Bloc de notas, haga clic en Archivo > Abrir.
- En la interfaz Nombre de archivo campo, escriba C:\Windows\System32\Drivers\etc\hosts.
- Haga clic en Abra.
- Realice los cambios necesarios en el archivo.
- Haga clic en Archivo > Guardar para guardar los cambios.
Windows NT, Windows 2000 y Windows XP
- Haga clic en Inicio > Todos los programas > Accesorios > Bloc de notas.
- Haga clic en Archivo > Abrir.
- En la interfaz Nombre de archivo campo, escriba C:\Windows\System32\Drivers\etc\hosts.
- Haga clic en Abra.
- Realice los cambios necesarios en el archivo.
- Haga clic en Archivo > Guardar para guardar los cambios.
Linux
- Abra una ventana de terminal.
- Abra el menú hosts en un editor de texto (puede utilizar cualquier editor de texto) escribiendo la siguiente línea:
sudo nano /etc/hosts
- Introduzca la contraseña de su usuario de dominio.
- Realice los cambios necesarios en el archivo.
- Presione Control-x.
- Cuando se le pregunte si desea guardar los cambios, responda y.
Mac OS X 10.0 a 10.1.5
- Abra /Applications/Utilities/NetInfo Manager.
- Para permitir la edición de la base de datos de NetInfo, haga clic en el candado situado en la esquina inferior izquierda de la ventana.
- Introduzca la contraseña de su usuario de dominio y haga clic en OK.
- En la segunda columna de la vista del navegador, seleccione el nodo llamado
machines.
Verá entradas para-DHCP-,broadcasthost, ylocalhosten la tercera columna. - En la tercera columna, seleccione
localhost. - En el mensaje Editar menú, seleccione Duplicar. (La forma más rápida de crear una entrada nueva es duplicar una existente.)
Aparecerá una alerta de confirmación. - Haga clic en Duplicar.
Una nueva entrada llamadalocalhost copyaparece, y sus propiedades se muestran debajo de la vista del navegador. - Haga doble clic en el valor de la propiedad
ip_addresse introduzca la dirección IP del otro equipo. - Haga doble clic en el valor de la propiedad
namee introduzca el nombre de host que desea para el otro equipo. - Haga clic en el enlace
servesy seleccione Eliminar en el menú Editar menú. - En el mensaje Archivo menú, seleccione Guardar.
Aparecerá una alerta de confirmación. - Haga clic en Actualizar esta copia.
- Repita los pasos del 6 al 12 por cada entrada de host adicional que desee agregar.
- En el menú de NetInfo Manager, seleccione Salir.
No es necesario reiniciar el equipo.
Mac OS X 10.6 hasta 10.15 y versiones posteriores
- Abra Aplicaciones > Utilidades > Terminal.
- Abra el menú hosts el archivo escribiendo la siguiente línea en la ventana de terminal:
sudo nano /private/etc/hosts
- Cuando se le solicite, escriba la contraseña de su usuario de dominio.
- Edite el hosts archivo.
El archivo contiene algunos comentarios (líneas que comienzan con el#símbolo) y algunas asignaciones de nombre de host predeterminadas (por ejemplo, 127.0.0.1 – host local). Agregue sus nuevas asignaciones después de las asignaciones predeterminadas. - Guarde el archivo hosts pulsando Control+x y responder y.
dscacheutil -flushcache sudo killall -HUP mDNSResponderLas nuevas asignaciones ya deberían surtir efecto.
Tell us what you need
Compare available plans or describe your workload so we can discuss a suitable starting point.